杭电1159(Common Subsequence)LCS和dp
来源:程序员人生 发布时间:2015-06-16 08:44:58 阅读次数:3399次
点击打开杭电1159
Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc abfcab
programming contest
abcd mnp
Sample Output
代码实现:
import java.util.*;
class Main {
static int[][] dp;
public static void main(String[] args){
Scanner sc=new Scanner(System.in);
while(sc.hasNext()){
String str1=sc.next();
String str2=sc.next();
lcs(str1,str2);
System.out.println(dp[str1.length()][str2.length()]);
}
}
public static void lcs(String str1,String str2){
int i,j;
dp=new int[str1.length()+1][str2.length()+1];
for(i=1;i<=str1.length();i++){
for(j=1;j<=str2.length();j++){
if(str1.charAt(i⑴)==str2.charAt(j⑴)){
dp[i][j]=dp[i⑴][j⑴]+1;
}else{
dp[i][j]=Math.max(dp[i⑴][j], dp[i][j⑴]);
}
}
}
}
}
生活不易,码农辛苦
如果您觉得本网站对您的学习有所帮助,可以手机扫描二维码进行捐赠