hdu 5050 Divided Land---2014acm上海赛区网络赛
来源:程序员人生 发布时间:2014-10-08 11:02:51 阅读次数:2021次
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5050
Divided Land
Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 115 Accepted Submission(s): 57
Problem Description
It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for
the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.
Input
The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve.
Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 21000)
Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number
or space.
Sample Input
3
10 100
100 110
10010 1100
Sample Output
Case #1: 10
Case #2: 10
Case #3: 110
Source
2014 ACM/ICPC Asia Regional Shanghai Online
Recommend
hujie | We have carefully selected several similar problems for you: 5052 5051 5049 5048 5046
Statistic | Submit | Discuss | Note
用java大数类取个gcd就完了。。。一开始手写了下gcd居然还共享了一次wa.......ORZ
import java.util.*;
import java.math.*;
public class Main {
public static void main(String [] args)throws Exception{
Scanner cin=new Scanner(System.in);
BigInteger one=new BigInteger("1");
BigInteger zero=new BigInteger("0");
BigInteger two= new BigInteger("2");
BigInteger four= new BigInteger("4");
BigInteger six = new BigInteger("6");
BigInteger A;
BigInteger B;
int T;
T=cin.nextInt();
for(int tt=1;tt<=T;tt++){
String a,b;
a=cin.next();b=cin.next();
A=new BigInteger(a,2);
B=new BigInteger(b,2);
BigInteger ans=A.gcd(B);
System.out.print("Case #"+tt+": ");
System.out.println(ans.toString(2));
}
}
}
生活不易,码农辛苦
如果您觉得本网站对您的学习有所帮助,可以手机扫描二维码进行捐赠